659 vues
[FAQ] Erreur 500, erreur d'URL, .htaccess, mod rewrite & cie
FoxLey

25 sujets, 574 réponses

Staff
Message non lu
NeoFrag CMS utilise les réécritures d'urls, cela permet d'avoir les liens joliment formés et optimisé pour le référencement.
Pour ce faire, il faut activer le mod rewrite du serveur Apache, cela se fait via le fichier .htaccess.

Cependant, selon les hébergeurs et leurs configurations d'Apache, cela peut causer certains bugs.
Ce n'est pas utile de référencer ces bugs, alors voici les fichiers .htaccess qui fonctionnent pour les hébergeurs récalcitrants :


Easy-Hebergement.fr
Options -Indexes
AddDefaultCharset UTF-8

<IfModule mod_rewrite.c>
RewriteEngine On

##If your NeoFrag directory is not at http root
##you need to replace "/" by the correct directory, for example "RewriteBase /neofrag/"
RewriteBase /

RewriteRule index\.php - [L]

##Allow direct access to specific directories
#RewriteCond %{REQUEST_URI} ^/(dir1|dir2)/
#RewriteRule .* - [L,QSA]

RewriteCond %{REQUEST_URI} !^/backups/

##Allow direct access to specific files
#RewriteCond %{REQUEST_FILENAME} /file1\.php [OR]
#RewriteCond %{REQUEST_FILENAME} /file2\.php [OR]

RewriteCond %{REQUEST_FILENAME} \.(png|jpg|jpeg|gif|swf|eot|svg|ttf|woff|woff2|zip)$
RewriteCond %{REQUEST_FILENAME} -f
RewriteRule .* - [L,QSA]

RewriteCond %{REQUEST_URI} \.html
RewriteRule (.*)\.html(.*) $1$2 [R=301,L]

RewriteRule .* index.php [E=REMOTE_USER:%{HTTP:Authorization},L,QSA]
</IfModule>

GitHub
23 participants
40 réponses
DARKOY

10 sujets, 43 réponses

Donateurs
Message non lu
Merci je t'aime mais sa marche pas MDR
baboy

14 sujets, 59 réponses

Donateurs
Message non lu
je viens d'avoir confirmation le staff de chez verygames le mod rewrite activé sur tous les serveurs

mais toujours impossible d'installer neofrag :( je péte un plomb
baboy

14 sujets, 59 réponses

Donateurs
Message non lu
sa fonctionne !!!!!! merci a MAJIID pour son aide ;)
VirusGamers

7 sujets, 83 réponses

Message non lu
Bon, pour moi cela ne fonctionne pas chez Easy-hébergement... Catastrophe sur catastrophe.
Fred

32 sujets, 155 réponses

Donateurs
Message non lu
Bonjour,

Je viens de changer de serveurs chez 1&1, passage d'un virtuel à un cloud.
j'ai activé l'url rewriting par la commande a2enmod rewrite, jusque là tout va bien.

Mais les liens ne fonctionnent pas avec ou sans .htaccess.
Qu'aurai-je oublié ???

[Edit] j'avais oublié de mettre AllowOverride All de ce fait le fichier .htaccess n'était pas pris en compte.

Mon site test : http://www.kylucrew.fr
xM3TALx

3 sujets, 27 réponses

Message non lu
Moi j'ai un soucis avec ce fichier, je suis cher franceserv comme hébergeur web, donc si quelqu'un pourrais m'aider avec sa pour que je puisse enfin utiliser mon site, s'il vous plait ^^
majiid

31 sujets, 281 réponses

Contributeurs Donateurs
Message non lu
passe sur le teamspeak tu aura l'aide qu'il te faut
xM3TALx

3 sujets, 27 réponses

Message non lu
Ok merci ^^
MetyuKrasnym

1 sujet, 3 réponses

Message non lu
Pour information, sur l'hébergement https://www.one.com/ il faut aussi mettre le RewriteBase /neofrag/.
baboy

14 sujets, 59 réponses

Donateurs
Message non lu
je viens d'installer la nouvelle version et j'ai un message d'erreur " Internal Server Error " , j'ai tester tous et toujours rien :(
eResnova

17 sujets, 875 réponses

Contributeurs Staff
Message non lu
Salut baboy,

Il faut surement que tu réutilise le même fichier .htaccess que tu avais modifié à l'origine pour faire fonctionner ton site ;)
baboy

14 sujets, 59 réponses

Donateurs
Message non lu
c'est ce que j'ai fait
Zaekof

38 sujets, 886 réponses

Contributeurs Donateurs
Message non lu
Bonjour, j'ai un problème de mon coté, je suis chez PulseHeberg est quand je veut allez sur mon site il me dit " 500 Internal Server Error" j'ai essayé de m'être le chmod 755, de modifier mon htaccess mais rien ni fait..

Vous savez pas de ou sa peut venir ?
"N'arrêtez jamais d'apprendre" !
Zaekof

38 sujets, 886 réponses

Contributeurs Donateurs
Message non lu
peut être que chez eux ils sont en version 2.4 de Apache,

j'ai essayé de créer des logs mais ils ne se créé même pas...

J'ai fait comme ceci, deja j'ai regardé le chemin d'acces : echo dirname(__FILE__); ça me donne : /var/www/wq7yal/www/site

j'ai donc modifié mon .htaccess :

"
Options +FollowSymLinks -Indexes
AddDefaultCharset UTF-8

<IfModule mod_rewrite.c>
RewriteEngine On
RewriteLog "/var/www/wq7yal/www/neofrag/rewrite.log"
RewriteLogLevel 9
RewriteBase /site

RewriteRule ^humans.txt$ ajax/settings/humans.txt
RewriteRule ^robots.txt$ ajax/settings/robots.txt
RewriteRule ^noscript.html$ ajax/settings/noscript.html

RewriteCond %{REQUEST_FILENAME} !index.php

RewriteRule (.*) index.php?request_url=$1 [E=REMOTE_USER:%{HTTP:Authorization},L,QSA]
</IfModule>

"
"N'arrêtez jamais d'apprendre" !
MrDonuts

11 sujets, 87 réponses

Donateurs
Message non lu
Bonsoir à tous, je fait un test de Neofrag sur Uwamp en local pour voir si je peux me débrouiller tout seul, bon !! j'ai déjà réussi à faire le plus gros en cherchant sur le site et mon ami google, par contre j'ai beau cherché sur le fofo et google, mais g pas trouvé mon bonheur, si j'ai bien suivit, il semblerai que cela viendrai du fichier htaccess je crois.
je mets l'erreur que j'ai sous Uwamp. merci à vous pour l'aide.

edit: j'arrive sur l'accueil du site, mais des que je clic sur un onglet, j'ai cette erreur, voilà, merci.