661 vues
[FAQ] Erreur 500, erreur d'URL, .htaccess, mod rewrite & cie
FoxLey

25 sujets, 574 réponses

Staff
Message non lu
NeoFrag CMS utilise les réécritures d'urls, cela permet d'avoir les liens joliment formés et optimisé pour le référencement.
Pour ce faire, il faut activer le mod rewrite du serveur Apache, cela se fait via le fichier .htaccess.

Cependant, selon les hébergeurs et leurs configurations d'Apache, cela peut causer certains bugs.
Ce n'est pas utile de référencer ces bugs, alors voici les fichiers .htaccess qui fonctionnent pour les hébergeurs récalcitrants :


Easy-Hebergement.fr
Options -Indexes
AddDefaultCharset UTF-8

<IfModule mod_rewrite.c>
RewriteEngine On

##If your NeoFrag directory is not at http root
##you need to replace "/" by the correct directory, for example "RewriteBase /neofrag/"
RewriteBase /

RewriteRule index\.php - [L]

##Allow direct access to specific directories
#RewriteCond %{REQUEST_URI} ^/(dir1|dir2)/
#RewriteRule .* - [L,QSA]

RewriteCond %{REQUEST_URI} !^/backups/

##Allow direct access to specific files
#RewriteCond %{REQUEST_FILENAME} /file1\.php [OR]
#RewriteCond %{REQUEST_FILENAME} /file2\.php [OR]

RewriteCond %{REQUEST_FILENAME} \.(png|jpg|jpeg|gif|swf|eot|svg|ttf|woff|woff2|zip)$
RewriteCond %{REQUEST_FILENAME} -f
RewriteRule .* - [L,QSA]

RewriteCond %{REQUEST_URI} \.html
RewriteRule (.*)\.html(.*) $1$2 [R=301,L]

RewriteRule .* index.php [E=REMOTE_USER:%{HTTP:Authorization},L,QSA]
</IfModule>

GitHub
23 participants
40 réponses
eResnova

17 sujets, 875 réponses

Contributeurs Staff
Message non lu
@Soulja si tu peux passer sur TeamSpeak dans 5min , je pourrai te donner un coup de main ;)
MrDonuts

11 sujets, 87 réponses

Donateurs
Message non lu
Ok @eResnova ça marche, merci
moonflower

1 sujet, 15 réponses

Message non lu
Bonjour je rencontre un souci avec l'installation sous l’hébergeur easy hébergement erreur 500

Internal Server ErrorThe server encountered an internal error or misconfiguration and was unable to complete your request.Please contact the server administrator, null@easy-hebergement.fr and inform them of the time the error occurred, and anything you might have done that may have caused the error.More information about this error may be available in the server error log.
Elkinas

0 sujet, 4 réponses

Message non lu
Hello, j'ai un soucis avec le htacess not found

Hebergeur: BlazingFast
Bandwidth used 11.10 GB
Tableau des utilisations CPU 0.02%
Espace disque 30 GB
Mémoire 512 MB
CPUs 1 x 2.50 GHz
Debian 7

site concerné:
Red Dragon Multigaming communauté Francophone

Logs:
[Tue Feb 09 020:17.226815 2016] [mpm_event:notice] [pid 1514:tid 140065154185088] AH00489: Apache/2.4.10 (Debian) configured -- resuming normal operations
[Tue Feb 09 020:17.226878 2016] [core:notice] [pid 1514:tid 140065154185088] AH00094: Command line: '/usr/sbin/apache2'
[Tue Feb 09 021:25.826936 2016] [mpm_event:notice] [pid 1514:tid 140065154185088] AH00493: SIGUSR1 received. Doing graceful restart
[Tue Feb 09 021:25.830795 2016] [mpm_event:notice] [pid 1514:tid 140065154185088] AH00489: Apache/2.4.10 (Debian) configured -- resuming normal operations
[Tue Feb 09 021:25.830808 2016] [core:notice] [pid 1514:tid 140065154185088] AH00094: Command line: '/usr/sbin/apache2'
[Tue Feb 09 021:28.140436 2016] [mpm_event:notice] [pid 1514:tid 140065154185088] AH00491: caught SIGTERM, shutting down
[Tue Feb 09 021:29.295567 2016] [mpm_prefork:notice] [pid 4281] AH00163: Apache/2.4.10 (Debian)


Cordialement,
Elkinas

En vous remerciant d’avance
Zaekof

38 sujets, 886 réponses

Contributeurs Donateurs
Message non lu
bonjour, vous avez résolu votre problème ?
"N'arrêtez jamais d'apprendre" !
majiid

31 sujets, 281 réponses

Contributeurs Donateurs
Message non lu
Bonjour @Elkinas
Par défaut la configuration Apache ne prend pas en compte votre fichier htaccess. Pour résoudre votre problème rendez-vous dans " /etc/apache2/sites-available/", si vous utilisé la configuration par défaut éditez le fichier "default" ou "default-ssl" si vous utilisé la version https.
Cherchez les dans les différentes ligne l'option "AllowOverride None" & remplacez le par "AllowOverride All" vous devriez obtenir une config similaire a ceci:

<Directory /var/www/>
Options Indexes FollowSymLinks MultiViews
AllowOverride All
Order allow,deny
allow from all
</Directory>

Si vous avez pas résolut le problème je pourrai vous aidez ;)
Papychampi

0 sujet, 1 réponse

Message non lu
Bonjour à tous!

Je ne tourne pas sous Apache2 mais sous lighttpd et je voudrais savoir si l'un d'entre vous serait comment gérer avec lui?

Merci par avance!

Papychampi
majiid

31 sujets, 281 réponses

Contributeurs Donateurs
Message non lu
bonsoir @Papychampi

Pour lighttpd c'est le même principe que nGinx il ne prend pas du tous en compte les fichier htaccess donc les règles doivent être mise dans la configuration de lighttpd. Je t'aurai bien dit d'utilisé le bous de code qui a dans le fichier xginx.conf car sa a l'aire similaire mais j'ai peur que sa marche pas.

Si foxley passe par la il t'aidera si non fait un UP demain j'installerai lighttpd & je ferais les tests ;)
Crimson-Sky

1 sujet, 55 réponses

Donateurs
Message non lu
Bonjour,

j'ai une erreur 500 la version 0.1.3 fonctionne bien mais la 0.1.4 me donne cette erreur:

[Wed May 11 18:06:30.089603 2016] [:error] [pid 13868] [client **.***.***.***:62789] PHP Fatal error: Call to undefined method mysqli_stmt::get_result() in /var/www/html/web1/neofrag/databases/mysqli.php on line 116

Merci de l'aide.
FoxLey

25 sujets, 574 réponses

Staff
Message non lu
Ton hébergeur ne gère pas mysqli native driver
Il faut simplement que tu remettes le driver mysql
GitHub
Crimson-Sky

1 sujet, 55 réponses

Donateurs
Message non lu
Merci de l'info

j'ai vue pour activer mysqli (le serveur et à moi).
arenakill

1 sujet, 6 réponses

Message non lu
Perso moi je suis chez LWS qui soutien nos site web depuis 2009 et depuis la mise a jour de Néo ben BIME erreur:ERROR 500 - INTERNAL SERVER ERROR aussi :-(
Plus moyen de me connecter en passant.Je sais pas si cette erreur va vraiment être corrigée car apparemment ce n'est pas qu chez certains mais je viens de tout ré-installer pour être sûr et aucunes solution...
NiReaS

0 sujet, 3 réponses

Message non lu
Bonjour,

Est-ce que quelqu'un a trouvé une solution pour lighttpd par hasard ? car cela m'aiderai beaucoup. Je suis actuellement bloqué au changement de page par l'erreur 404, sûrement dû au mod_rewrite.

Merci d'avance
Zaekof

38 sujets, 886 réponses

Contributeurs Donateurs
Message non lu
bonjour,

tu peut essayer ça : http://stackoverflow…
"N'arrêtez jamais d'apprendre" !
NiReaS

0 sujet, 3 réponses

Message non lu
Merci pour ta réponse rapide.
Je supprime la 2e règle et pas mal de chose fonctionne, mais pas tout:
- le login admin, quand mes identifiants sont correctes il ne se passe rien. Ce qui est très embêtant car je ne peux toujours pas le conf
- lorsque j'ouvre une news, il me dit "page not found" sur le site (pas une erreur 404 du serveur)
- lorsque que j'ouvre un forum idem